L2 restaking not working

Hi, been spending the last weeks exploring the new very exciting environment that is evolving at an impressive pace. Truly a new chapter is being written in the crypto history books. However, I am unable to participate in the L2 restaking initiative…Tried all possible options: accessing the page via link from ether.fi, or directly via the Swell website doesnt make any difference. I have tried to restake ETH as well as rswETH; same result. After specifying what and how much, I hit the yellow approve button. On the screen a small window appears to the bottom left “Approve pending” , it has a yellow bar showing the progress,but doesnt move, and times out after some minutes. Trying with ETH instead of rswETH same result, the only difference is that the yellow button has “zap in” instead of “approve” and the appearing small window changes from “Approve pending” to “zap pending”. …please advice, spent hours trying to get this to work… Regards B

Gm Granis, thanks for the kind words and welcome to Swell! If you’re experiencing issues when depositing it will be easier for our team to check if you open a support ticket in our Discord (beware of scammers!) and share your wallet address / screenshots of any errors that appear. We haven’t had anyone report this issue so it’s difficult to know what’s wrong.